网站如何适用于经典编辑器支持旧版WordPress

2019.09.15 - 象牙白

支持旧版WordPress

一旦WordPress 5.3发布,Yoast将只支持WordPress 5.2和WordPress 5.3,而不是之前的版本。这意味着我们将终止对WordPress 4.9的支持,我们将保持比平常更长的时间,以允许人们过渡到WordPress 5.0和经典编辑器。我想解释为什么我们有这个政策以及为什么我们决定回到它。

为WordPress构建软件可能非常复杂。我们的工作环境总是有几个版本的WordPress。接下来,插件几乎可以做任何事情(他们这样做),这也意味着它们可以相互干扰。每个站点都有不同的插件组合,导致数以万计的不同组合。

现代代码
在Yoast,我们为使用最好的工具为我们的用户构建解决方案感到自豪。使用WordPress 5.2,WordPress核心团队将WordPress的最低PHP要求从PHP 5.2提升到PHP 5.6。我们总是希望我们的软件能够满足WordPress的最低要求,这意味着我们只能使用PHP 5.2中的功能。

注意:我知道这些版本号以及它们如此相似的事实会让人感到困惑。我们内心肯定有一些混乱。我提前为此道歉,但正如您所理解的,我无法更改这些版本号。

PHP是大多数WordPress后端内置的语言.PHP 5.2于2006年发布,而PHP 5.6于2014年发布。正如您所看到的那样,相隔8年,8年是非常长的互联网时间。

回到我们仅支持当前和以前版本的策略,因此只支持WordPress 5.2和5.3,我们允许自己使用PHP 5.6进行开发。因为我们现在可以使用PHP 5.6,所以我们可以更快,更安全地开发。

“支持”是什么意思?
当我们说我们不支持旧版本的WordPress时,这意味着我们已经停止使用它进行测试,事情很可能会破裂。这也意味着在将WordPress更新为支持的版本之前,您不会看到Yoast SEO更新。

我的网站不适用于经典编辑器
对于一小部分网站,我知道这让他们陷入困境,我们讨厌。如果您有一个自定义WordPress解决方案,使用旧版本的插件(如高级自定义字段(ACF))构建,您可能会“卡住”。尽管ACF在迁移到古腾堡方面做得非常出色,但这可能不会“拯救”你。

虽然我们认为这很糟糕,但除了去网站开发人员并向他们解释这不是你想要留下的状态之外,我们对你没有任何选择。你真的应该转向更新版本的WordPress。我们将继续支持经典编辑器多年,所以如果他们能够使用它,你就会很好。

我没有看到任何Yoast SEO更新
有几个不同的原因,你不能看到Yoast SEO更新。如上所述:如果您使用的是旧版WordPress,则不会看到它们。所以首先更新你的WordPress。如果不是这样,请重新安装插件,只需删除它并手动安装最新版本。那不会删除你的任何数据,不用担心。

去更新您的网站!
所以,如果您使用的是旧版WordPress,请进行更新。当然,做之前什么样更新插件或WordPress的,始终确保测试和备份您的网站!




阅 143
0

恒达主管_@首页【主管:330060800】人生中没有过不去的明日,恒达主管没有到不了的远方,恒达主管告知咱们 […]